Пожалуйста! Помогите с программкой
Миша любил рисовать треугольники, но делал он это необычным способом. Сначала рисовал произвольный треугольник, потом каждую сторону делил на n равных частей и проводил через точки раздела прямые, параллельные сторонам треугольника. В результате получается несколько равных между собой треугольников. Помогите Мише найти наибольшее количество полученных одинаковых треугольников.
Входные данные
Целое число n (0 < n < 2*109).
Выходные данные
Искомое количество равных между собой треугольников.
на языке C++
#include
int main()
{
int64_t n;
// __int64 n; для visual studio
std::cin >> n;
std::cout << n*n << std::endl;
return 0;
}
/**
Покажем, что количество равных треугольников равно n^2.
Обозначим ответ к задаче как f(n).
При n = 1 имеем f(n) = 1, так как треугольник не разрезается.
Переходим от n-1 к n.
При переходе добавляется два нижних ряд треугольников.
В одном n треугольников и они ориентированы так же, как и исходный треугольник.
В другом -- n-1 треугольник, и они зеркально симметричны исходному треугольнику.
Итого, f(n) = f(n-1) + n + n-1 = f(n-1) + 2n-1.
Теперь заметим, что n^2 при n=1 равно 1^2 = 1;
n^2 = (n-1 + 1)^2 = (n-1)^2 + 2(n-1) + 1 = (n-1)^2 + 2n-1.
То есть f(n) = n^2.
Итого, искомое количество треугольников: n^2
*/