Помогите написать программу на паскале
Срочно
вывести квадраты и кубы 10 чисел следущей последовательности: 1, 2, 4, 7, 11, 16..
Данная последовательность -- последовательность центральных многоугольных чисел. Вычисляется по формуле a(n) = n*(n+1)/2 + 1. Или a(1) = 1, a(n+1) = a(n) + n.
Var
a, i: integer;
Begin
a := 1;
for i := 1 to 10 do
begin
writeln(base=, a, square=, a*a, cube=, a*a*a);
inc(a, i);
end
End.
Оцени ответ
