Задание очень срочное!!! Нужно до 22.00 05.11.2015!!!
Написать программу, которая заменяет цифру числа названием этой цифры.
Например, заменить число 4563 на строку четыре пять шесть три.
ПАСКАЛЬ!!!

Var
  n: integer;
  answer: string;
 
begin
  read(n);
  while n > 0 do {Пока есть цифры добавляем последнюю цифру числа к ответу и отбрасываем ее}
  begin
    case n mod 10 of
      0: answer := ноль + answer;
      1: answer := один + answer;
      2: answer := два + answer;
      3: answer := три + answer;
      4: answer := четыре + answer;
      5: answer := пять + answer;
      6: answer := шесть + answer;
      7: answer := семь + answer;
      8: answer := восемь + answer;
      9: answer := девять + answer;
    end;
    n := n div 10;
  end;
  writeln(answer);
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку