Написать программу определения знака результата деления двух чисел в зависимости от знаков этих чисел.
Написать в паскале.
Var s1,s2:string;
begin;
writeln(Введите исходные знаки);
readln(s1);
readln(s2);
if ((s1<>-) and (s1<>+)) or ((s2<>-) and (s2<>+)) then
begin;
writeln(Ошибка);
exit;
end;
if ((s1=+) and (s2=+)) or ((s1=-) and (s2=-)) then writeln(+) else writeln(-);
end.
С числами:
var a,b:integer;
begin;
writeln(Делимое:);
readln(a);
writeln(Делитель);
readln(b);
if b=0 then
begin;
writeln(Нельзя делить на ноль. Если это, конечно, не JavaScript.);
exit;
end;
if a=0 then
begin;
writeln(0);
exit;
end;
if ((a>0) and (b>0)) or ((a<0) and (b<0)) then writeln(+) else writeln(-);
end.
Оцени ответ
