Написать программу, ожидающую от пользователя число (номер года) и выводящую информацию о том, високосный этот год или нет

В григорианском календаре високосным является:
- год, номер которого делится нацело на 400
- год, номер которого делится на 4, но не делится на 100
Программа на паскале:
var n: integer;
begin
  read(n);
  if (n mod 400 = 0) or (n mod 4 = 0) and (n mod 100 > 0)
  then writeln(n, год високосный)
  else writeln(n, год невисокосный);
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку