Написать программу, которая запрашивает массив из N целых чисел, а затем складывает все элементы с нечетными номерами и все элементы с четными номерами и выводит их сумму, а также сам исходный массив.
ПОМОГИТЕ ПОЖАЛУЙСТА! Спасибо.
Program al;
const n=10;
var a:array[1..n] of integer;
s,s1,s2,i:integer;
begin
writeln(vvedite danniy massiv=);
for i := 1 to n do
readln(a[i]);
s:=0;
s1:=0;
s2:=0;
for i := 1 to n do
if i mod 2=0 then s1:= s1+a[i] else
begin
s2:=s2+a[i];
s:=s1+s2;
end;
writeln(ishodniy massiv=);
for i := 1 to n do
write (a[i]:4);
writeln( summa=,s);
readln;
end.
Оцени ответ
