Массив из 10 элементов вводится с клавиатуры. Составить программу расчёта среднего арифметического любых двух элементов массива (номера элементов вводятся с клавиатуры).

Шо-то изи

int[] a = new int[10];
Scanner scn = new Scanner(System.in);
for (int i = 0; i < a.length; i++)
a[i] = scn.nextInt();
System.out.println("Input 2 number, to choose numbers from massive");
int b = scn.nextInt();
int c = scn.nextInt();
System.out.println((a[b] + a[c]) / 2);

Проверка:
$ javac Main.java
1 2 3 4 5 6 7 8 9 10
1 5
4

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку