Задание: Составьте программу ввода с клавиатуры элементов массива a[1..10] и вывода на экран элементов, значения которых являются квадратами целых чисел. Вот что я составил, но извлечение корня нельзя делать в integer:( Помогите! Program shist;
Var a: array [1..10] of integer;
i: integer;
Begin
writeln(ВВедите элементы массива:);
readln(i);
writeln(Элементы массива, значения которых являются квадратами целых чисел:);
For i:=1 to 10 do
if sqrt(i) then
write (a[i], )
End.

Текст программы на языке Паскаль:

program _1;
const N=10;
var i: integer; 
a: array[1..N] of integer;
begin
for i:=1 to N do begin
readln(a[i]);
a[i]:=a[i]*a[i];
end;
for i:=1 to N do begin
writeln(a[i]);
end;
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку