
Составьте программу ввода с клавиатуры элементов массива a[1..10] и вывода на экран элементов значения которых являются квадратами целых чисел

Var ar:array[1..10] of real;
i:integer;
begin;
for i:=1 to 10 do
readln(ar[i]);
writeln(OK:);
for i:=1 to 10 do
if frac(sqrt(ar[i]))=0 then writeln(ar[i]);
end.
Оцени ответ