1.с клавиатуры вводится n действительных чисел. Определить сколько в данной последовательности нечетных отрицательных чисел.
2.Составить программу на языке Паскаль вычисления кубов чисел вводимых с клавиатуры.
3.Написать программу вычисления положительных чисел.Записать варианты программы с разными видов циклов.

Первая:
Uses crt;
Var arr:array[1..100] of integer;
n,a,c:integer;
Begin
Write(Сколько чисел вы хотите ввести?-);
Readln(n);
for a:=1 to n do
begin
Write(Введите ,a, число:);
Readln(arr[a]);
end;c:=0;
For a:=1 to n do
Begin
if  (arr[a] mod 2<>0) and (arr[a]<0) then c:=c+1;
end;
Writeln(В последовательности ,c, нечетных отрицательных чисел.);
end.


Вторая:
Uses crt;
Var arr:array[1..100] of integer;
a,b,c,m:integer;
begin
Write(Сколько чисел вы хотите ввести?-);
Readln(b);
For a:=1 to b do
begin
Write(Введите ,a, число:);
Readln(arr[a]);
end;
For a:=1 to b do
Begin
m:=arr[a];
For c:=1 to 2 do
begin
arr[a]:=m*arr[a];
end;end;
For a:=1 to b do
begin
 Writeln(Куб ,a, введенного вами числа равен:,arr[a]);
end;
end.


Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку
×