Даны два натуральных числа n и m. Если одно из них делится на другое нацело, выведите 1, иначе выведите любое другое целое число.
Входные данные
Вводятся два числа.
Выходные данные
Выведите ответ на задачу. (Примеры : входные данные - 2,8. выходные - 1).
P.S. Решить надо в Паскаль АБЦ!

// PascalABC.Net 3.0, сборка 1052
var
  m, n: longint;

begin
  Read(m, n);
  if (m = 0) and (n <> 0) or (n = 0) and (m <> 0) then Writeln(1)
  else
    if (m = 0) and (n = 0) then Writeln(0)
    else
      if (m div n = 0) or (n div m = 0) then Writeln(1)
      else Writeln(0)
end.

Тестовое решение:
2 8
1

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку
×