помогите пожалуйста решить задачу в паскале:
Составить программу,проверяющую,является ли заданное натуральное число палиндромом,т.е. таким,которое читается одинаково слева направо и справа налево(например:23132).
var n, m, p: word;
begin
write(Enter number: );
readln(n);
m := n;
p := 0;
while m > 0 do begin
p := p * 10 + m mod 10;
m := m div 10;
end;
if n = p then
writeln(Palindrome)
else
writeln(Not palindrome);
readln;
end.
Оцени ответ
