Дано число n. С начала суток прошло n минут. Определите, сколько часов и минут будут показывать электронные часы в этот момент. Входные данные Вводится число n - целое, положительное, не превышает 107. Выходные данные Программа должна вывести два числа: количество часов (от 0 до 23) и количество минут (от 0 до 59). Учтите, что число n может быть больше, чем количество минут в сутках.
//Pascal ABC.NET Версия 2.2 Сборка 790
var n,h,m:integer;
begin;
readln(n);
if (n<0) or (n>107) then exit; //странное ограничение
h:=n div 60;
m:=n mod 60;
while h>=24 do
h:=h-24;
writeln(h,:,m);
end.
Пример ввода:
106
Пример вывода:
1:46
Оцени ответ
