составить программу, которая заполняет массив а [1..10] случайными целыми числами в диапазоне от 0 до 10 и находит максимальный элемент массива среди элементов с чётными индексами

var

  a: array [1..10] of integer;

  i, max: integer;

 

begin

  max:= 0;

  write(Исходный массив:  );

  for i:= 1 to 10 do

  begin

    a[i]:= random(10);

    write(a[i],  );

    if (i mod 2 = 0) and (a[i] > max) then

      max:= a[i];

  end;

  writeln;

  writeln(Максимальный элемент массива среди элементов с четными индексами: , max);

end.

Если что не понятно - спрашивай.    

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку