Очень срочно! Нужна ваша помощь!
Написать программу на паскале: сформировать матрицу и найти наименьшее среди средних арифметических элементов ее столбцов.( В ответе достаточно рабочего кода)
Const n=5; m=6;
var a: array [1..n,1..m] of integer;
sum,min,i,j:integer;
begin
Randomize;
writeln(---A:---);
for i:=1 to n do begin
for j:=1 to m do begin
a[i,j]:=Random(20)-10;
write(a[i,j]:6);
end;
writeln;
end;
writeln(Среднее арифм. столбцов:);
min:=100000;
for j:=1 to m do begin
sum:=0;
for i:=1 to n do sum:=sum+a[i,j];
write(sum/n:6:2);
if sum
writeln;
writeln(Min=,min/n:6:2);
end.
Оцени ответ
