Помогите, пожалуйста, составить программу!!! Паскаль.
1. Из строки символов удалить самое длинное слово (тема: строковые и символьные величины).

Var st: string;
     i,begs,ind,maxs: integer;
begin
  write(задайте строку:  );
  readln(st);
  begs:=1;  maxs:=1;
  for i:=1 to Length(st) do
   begin
    if st[i]=chr(32) then
    begin
      if maxs<(i-begs) then
      begin
        maxs:=i-begs;
        ind:=begs;
      end;
      begs:=i+1;
    end;
  end;
  Delete(st,ind,maxs);
  writeln(новая строка:  ,st);
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку