ПОМОГИТЕ ПОЖАЛУЙСТА!!

№1
Даны числа a, b, c, составляющие стороны треугольника и числа d,
f, составляющие стороны прямоугольника. Написать программу,
определяющую, площадь какой фигуры больше.
№2
Даны объёмы и массы двух тел из разных материалов. Написать
программу, определяющую плотность какого материала больше.
№4

Пользовать вводит с клавиатуры два числа a и b. Написать
программу, определяющую:
1). является ли число a делителем числа b;
2). является ли число b делителем числа

1)

var
    a, b, c, d, f : Integer;
   S : Real;
begin

 

   Writeln( Введите стороны треугольника: );
   Write( a = ); Readlln( a );
   Write( b = ); Readlln( b );
   Write( c = ); Readlln( c );


   Writeln( Введите стороны прямоугольника: );
   Write( d = ); Readlln( d );
   Write( f = ); Readlln( f );

   S := (a + b + c) / 2;
   S := sqr( S * (S-a) * (S-b) * (S-c) );

   if (d * f) = S then
      Writeln( S прямоугольника = S треугольника. )
   else if (d * f) > S then
      Writeln( S прямоугольника больше. )
   else
      Writeln( S треугольника больше. );

   Readln;
end.

 

2)

var
   m, V, m1, V1 : Integer;
begin

   Writeln( Введите объем и массу первого тела: );
   Write( m = ); Readlln( m );
   Write( V = ); Readlln( V );


   Writeln( Введите объем и массу второго тела: );
   Write( m = ); Readlln( m1 );
   Write( V = ); Readlln( V1 );

   if (m / V) = (m1 / V1) then
      Writeln( Плотности равны. )
   else if (m / V) > (m / V) then
      Writeln( Плотность первого тела больше. )
   else
      Writeln( Плотность второго тела больше. );

   Readln;
end.

 

3)

var
    a, b : Integer;
begin

 

   Writeln( Введите числа: );
   Write( a = ); Readlln( a );
   Write( b = ); Readlln( b );


   if a mod b = 0 then
      Write( Число a является делителем числа b. );

   if b mod a = 0 then
      Write( Число b является делителем числа a. );

   Readln;
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку