Дано три числа, записанный в отдельных строках. Упорядочите их в порядке неубывания. Программа должна считывать три числа a, b, c, затем программа должна менять их значения так, чтобы стали выполнены условия a <= b <= c, затем программа выводит тройку a, b, c.
Входные данные:
Вводятся три числа, каждое записано в отдельной строке.
Выходные данные:
Выведите ответ на задачу.
program abc;
var a,b,c : longint ;
begin
read(a,b,c);
if (a>=b>=c)then
write (a,b,c)
else
if (a>=c>=b) then
write (a,c,b)
else
if (b>=a>=c) then
write (b,a,c)
else
if (b>=c>=a) then
write(b,c,a)
else
if (c>=a>=b) then
write(c,a,b)
else
write(c,b,a);
end.
почему пишет ошибку "Операция >= не применима к типам boolean и integer" ?
отдам 20 баллов, только подскажите главное)

Главная ошибка в том, что нельзя записывать условие (a>=b>=c)
Надо это условие записывать так:
(a>=b) and (b>=c)

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку