Написать программу, определяющую возможность представления заданного натурального числа М в виде суммы двух квадратов натуральных чисел.
Program rabota_01;
var m, n: Longint;
i, j: Integer;
begin
Write(Введите M: ); ReadLn(m);
for i:=Trunc(Sqrt(m)) downto 1 do begin
n:=Sqr(i); j:=1; while (j<=i) and (n+Sqr(j)
WriteLn(m, = ,i,^2 + ,j,^2); Exit;
end;
end;
WriteLn(m, не является суммой квадратов натуральных чисел.);
end.
Оцени ответ
