Вычислить сумму ряда до n количества значений S=1+ 1/2+1/4+1/(8 )…
напишите программу в паскале
Не очень корректная постановка задачи, но понять можно.
var n,i:integer; s,a:real;
begin
write(n=);readln(n);
s:=1;a:=1;
for i:=2 to n do
begin
a:=a*2; s:=s+1/a;
end;
writeln(s=,s:6:4);
end.
Оцени ответ
