Питон. Последовательность состоит из различных натуральных чисел и завершается числом 0. Определите значение второго по величине элемента в этой последовательности. Гарантируется, что в последовательности есть хотя бы два элемента.

arr = [0, 1, 2, 3, 4, 5, 6, 7, 8, 9, 0] # Заполняем элементами массив
a = 0
b = 0
for i in range(len(arr)):
    if arr[i] > a:
        b = a
        a = arr[i]
print(b)

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку