Напишите программу для паскаля! Дано натуральное число! Найти число, получаемое удалением из исходного числа всех цифр а.

1. "Школьное" решение

// PascalABC.Net 3.0, сборка 1066
var
  s,s1:string;
  i:integer;
  a:char;
begin
  Write(Введите натуральное число любой длины :); Readln(s);
  Write(Введите цифру, которую надо удалить: ); Readln(a);
  s1:=;
  for i:=1 to Length(s) do
    if s[i]<>a then s1:=s1+s[i];
  Writeln(Результат: ,s1)
end.

Тестовый прогон:
Введите натуральное число любой длины :3141592653589793
Введите цифру, которую надо удалить: 5
Результат: 3141926389793

2. Современное решение (так в школе почему-то не учат)

// PascalABC.Net 3.0, сборка 1066
begin
  var s:=ReadString(Введите натуральное число любой длины :);
  var a:=ReadChar(Введите цифру, которую надо удалить: );
  Write(Результат: ,s.Replace(a,));
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку