Напишите программу для паскаля! Дано натуральное число. Найти число, получаемое удалением удалением из исходного всех цифр а.
Var n,m,k,p,a:integer;
begin
write(n=); readln(n);
write(a=); readln(a);
m:=0;p:=1;
while n<>0 do
begin
k:=n mod 10;
if k<>a then begin m:=k*p+m; p:=p*10; end;
n:=n div 10;
end;
writeln(m=,m);
end.
Оцени ответ
