Напишите программу для паскаль! Дано натуральное число. Установить, является ли последовательность его цифр при просмторе их справа налево упорядоченной по возрастанию.
Var n,k:integer; b:boolean;
begin
write(n=); readln(n);
b:=true;k:=0;
while n<>0 do
begin
b:=b and (n mod 10>k);
k:=n mod 10;
n:=n div 10;
end;
if b then writeln(Цифры числа упорядочены)
else writeln(Цифры числа не упорядочены);
end.
Оцени ответ
