Напишите программу для паскаля! Дано натуральное число. Найти число, получаемое из исходного перестановкой его первой и последней цифр.
Var a,bug:integer;
s,s1,s2:string;
begin;
readln(a);
str(a,s); //переводим число в строку
s1:=s[1]; //запоминаем 1 символ
s2:=s[length(s)]; //запоминаем крайний символ
delete(s,1,1); //удаляем 1 символ
delete(s,length(s),1); //удаляем крайний символ
insert(s2,s,1); //ставим сохранённый крайний символ на первое место
insert(s1,s,length(s)); //ставим сохранённый первый символ в конец
val(s,a,bug); //делаем строку числом, не забыв о возможности багов
writeln(a);
end.
Оцени ответ
