Составить программу для вычесления площади и периметра треугольника(известны все три стороны) при двух условиях: если треугольник прямоугольный и если нет, то через формулу герона. В Паскале нужна программа

Program zadanie;
var a, b, c, s, p, pp:real;
begin
writeln(Введите сторону a);
read(a);
writeln(Введите сторону b);
read(b);
writeln(Введите сторону c);
read(c);
p:=a+b+c;
pp:=p/2;
if (sqr(a)=sqr(b)+sqr(c)) then
begin
writeln(Прямоугольный треугольник с гипотенузой a);
s:=1/2*b*c;
writeln(Площадь = ,s);
end;
if (sqr(b)=sqr(a)+sqr(c)) then
begin
writeln(Прямоугольный треугольник с гипотенузой b);
s:=1/2*a*c;
writeln(Площадь = ,s);
end;
if (sqr(c)=sqr(b)+sqr(a))  then
begin
writeln(Прямоугольный треугольник с гипотенузой c);
s:=1/2*b*a;
writeln(Площадь = ,s);
end
else
begin
writeln(Непрямоугольный треугольник);
s:=sqrt(pp*(pp-a)*(pp-b)*(pp-c));
writeln(Площадь = ,s);
end;
writeln(Периметр = ,p);
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку