Написать программу, вычисляющую сумму и среднее арифметическое последовательности положительных чисел, которые вводятся с клавиатуры.
вид экрана:
Введите числа. Для завершения последовательности нажмите ноль.
45 23 15 0
введено чисел:3
сумма чисел:83
Среднее арифметическое:27.67
В задании не сказанно что числа целые поэтому тип c: real;
Program SumAndAvg;
Uses crt;
var n:integer;
c,s,m:real;
begin
clrscr;
write(Input Numbers:);
n:=0;s:=0;
repeat
read(c);
if (c>0) then
begin
n:=n+1;
s:=s+c;
end;
until (c=0);
writeln(Numbers count =,n);
writeln(Summa =,s:2:2);
writeln(Average Value=,s/n:2:2);
readkey;
end.
Оцени ответ
