помогите написать программу которая вычисляет сумму положительных из n введенных с клавиатуры целых чисел
(FOR) В паскале ABC
program z1; (Начало программы)
var n, s, i, c:integer; (Раздел описания переменных, n(кол-во чисел), s(сумма чисел), i(счетчик), с(число, введенное с клавиатуры))
begin (тело программы)
writeln (Кол-во чисел?); (подсказка для пользавателя)
readln (n); (считывание переменной)
s:=0; (обнуляем переменную)
For i:= 1 to n do begin (цикл будет повторяться от 1 до N; т.к в цикле будет несколько действий открываем операторные скобки (beginend), начало цикла)
writeln (Введите число); (подсказка для пользавателя)
readln(c); (считывание переменной)
If c>0 then s:=s+c; (если с>0 тогда к сумме мы прибавляем число)
end; (конец цикла)
writeln (Сумма=,s); (подсказка для пользавателя и ответ)
readln(s); (считывание переменной)
readln; (считывание)
end.(конец программы)
