Составить программу, в которой получить как можно больше слов, образованных из слова информатика. Вывести на экран длину исходного слова. (Программа на языке Паскаль, использовать команды: length, copy, delete, insert, concat.)
Желательно сделать до завтрешнего дня, информатика завтра будет. Заранее спасибо)
Из слова "информатика" так много всего можно сделать!
Вот небольшая часть:
var s,s1:string;
begin
s:=информатика;
//1 способ
s1:=copy(s,3,5);
writeln(s1,-,length(s1));
//2 способ
s1:=s;delete(s1,8,4);
delete(s1,1,2);
writeln(s1,-,length(s1));
//3
s1:=s;delete(s1,1,5);
delete(s1,3,2);
insert(copy(s,5,1),s1,3);
writeln(s1,-,length(s1));
//4
s1:=copy(s,5,1)+copy(s,4,1)+copy(s,6,2)+copy(s,2,1)+copy(s,8,3);
writeln(s1,-,length(s1));
//5
s1:=concat(copy(s,3,3),copy(s,8,1));
writeln(s1,-,length(s1));
end.
Оцени ответ
