Составить программу в PascalABC, которая запрашивает ввод буквы латинского алфавита, а потом для данной буквы напечатает справа стоящую букву на стандартной клавиатуре. При этом считается, что справа от буквы "P" стоит буква "A", от буквы "L" стоит буква "Z", от буквы "M" стоит буква "Q".

// PascalABC.NET 3.0, сборка 1073
const
  s=QWERTYUIOPASDFGHJKLZXCVBNMQqwertyuiopasdfghjklzxcvbnmq;
var
  c:char;
  p:integer;
begin
  repeat
    Write(Введите латинскую букву, иной символ завершит работу: );
    Readln(c);
    p:=Pos(c,s);
    if p>0 then Writeln(Рядом буква ",s[p+1],")
  until p=0
end.

Тестовое решение:
Введите латинскую букву, иной символ завершит работу: y
Рядом буква "u"
Введите латинскую букву, иной символ завершит работу: H
Рядом буква "J"
Введите латинскую букву, иной символ завершит работу: m
Рядом буква "q"
Введите латинскую букву, иной символ завершит работу: P
Рядом буква "A"
Введите латинскую букву, иной символ завершит работу: 5

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку