Вводится натуральное n и действительное x. Найти
y=Sin(x)+Sin(x^2)+Sin(x^3)+Sin(x^n) . Написать программу для турбо паскаля
{ Borland Pascal 7.01 }
uses Crt;
var
i,n:integer;
x,xp,y:real;
begin
ClrScr;
Write(n=); Read(n);
Write(x=); Read(x);
xp:=1; y:=0;
for i:=1 to n do begin xp:=xp*x; y:=y+sin(xp) end;
Writeln(y=,y);
ReadKey
end.
Тестовое решение:
n=8
x=1.535
y= 2.2418218291E+00
Оцени ответ
