Напишите программу да ABC pascal
// PascalABC.Net 3.0, сборка 1073
// Задача 1
var
x,y,t1,t2:real;
begin
Write(Введите объем и температуру для первого ведра: );
Read(x,t1);
Write(Введите объем и температуру для второго ведра: );
Read(y,t2);
Writeln(Объем смеси равен ,x+y,, температура равна ,
(x*t1+y*t2)/(x+y):0:1)
end.
// Задача 2
var
x,y:real;
begin
Write(Введите x: ); Read(x);
if x>5 then y:=sqr(x) else y:=x+3;
Writeln(y=,y)
end.
// Задача 3
var
t:integer;
begin
Write(Введите температуру воды: ); Read(t);
if t<=0 then Writeln(Твердое состояние)
else
if t>100 then Writeln(Газоообразное состояние)
else Writeln(Жидкое состояние)
end.
Оцени ответ
