На вход программе подается натуральное число n <= 109. Проверьте, является ли оно простым. Выведите YES или NO в зависимости от ответа на вопрос задачи. Максимальное время работы программы на одном тесте — 0,1 секунды.

Var
a,flag,i:integer;
Begin
Readln(a);
flag:=0;
for i:=2 to a do begin 
if i<>a then if a mod i=0 then 
begin flag:=1; break; end;  end;
if flag=1 then Writeln(NO)
else Writeln(YES)
End.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку