1.Перевести римскую цифру в арабское представление
(I-1,V-5,X-10,L-50,C-100,D-500,M-1000) организуйте проверку правильности вводимых символов
2.Составить программу для вычисления выражения в зависимости от введенного номера варианта( от 1 до 5)
1)x^2+y^2
2)(a+b)^2
3)(c-d)^2
4) |sinx|
5) sqrt(a^2+ b^2)
Составьте соответствующие отладочные примеры и проверьте работу каждой программы
// PascalABC.NET 3.0, сборка 1073
var
c:char;
begin
Write(Введите римскую цифру (I,V,X,L,C,D,M): ); Readln(c);
case c of
I:Writeln(1);
V:Writeln(5);
X:Writeln(10);
L:Writeln(50);
C:Writeln(100);
D:Writeln(500);
M:Writeln(1000);
else Writeln(Вы ошиблись)
end
end.
// PascalABC.NET 3.0, сборка 1073
var
n:byte;
x,y:real;
begin
Write(Введите номер варианта (1-5): ); Readln(n);
case n of
1:begin
Write(Выражение x^2+y^2, введите x,y: ); Read(x,y);
Writeln(Результат: ,sqr(x)+sqr(y))
end;
2:begin
Write(Выражение (a+b)^2, введите a,b: ); Read(x,y);
Writeln(Результат: ,sqr(x+y))
end;
3:begin
Write(Выражение (c-d)^2, введите c,d: ); Read(x,y);
Writeln(Результат: ,sqr(x-y))
end;
4:begin
Write(Выражение |sin(x)|, введите x: ); Read(x);
Writeln(Результат: ,abs(sin(x)))
end;
5:begin
Write(Выражение sqrt(a^2+b^2), введите a,b: ); Read(x,y);
Writeln(Результат: ,sqrt(sqr(x)+sqr(y)))
end;
else Writeln(Вы ошиблись)
end
end.
