Написать программу на алгоритмическом языке программирования для вычисления минимального отрицательного числа и максимального положительного числа из 15 чисел введенных с клавиатуры(Язык с++)
#include
using namespace std;
int main()
{
int x, Max, Min;
x=Max=Min=0;
for (int i=1;i<=15;++i) {
cin >> x;
if (x > Max) Max=x;
if (x < Min) Min=x;
}
cout << "Максимальное положительное число " << Max << " Минимальное отрицательное число " << Min << endl;
if (Max == 0 or Min == 0) cout << "Число 0 означает что такого значения нет" << endl;
}
Оцени ответ
