Составьте программу, которая запрашивает пол учеников (жили м) и их количество(от 5 до 30) и выдаёт сообщение.
Протокол: Введите пол и количество: ж 13 В классе сейчас тринадцать девочек
На Паскале
Ох и намудрил с этой программой))
program school;
var a:char;
b:real;
c,d:boolean;
begin
Writeln (Введите пол (м или ж) и количество учеников);
repeat
write (Пол - ); readln (a);
if upcase(a)=Ж then c:=true;
if upcase(a)=М then c:=true;
if c=true then write else
writeln (Вы должны ввести использовать символы "м" или "ж");
until c=true;
repeat
write (Количество учеников данного пола от 5 до 30 - ); readln (b);
if b<5 then d:=false else d:=true;
if b>30 then d:=false else d:=true;
if d=true then
begin
if upcase(a)=Ж then writeln (В классе сейчас ,b, девоч.);
if upcase(a)=М then writeln (В классе сейчас ,b, мальч.);
end;
until d=true;
end.
