Составьте программу которая позволяет ввести строки s, затем после каждой буквы "а" вставляет пробел. Pascal ABC, срочно

// PascalABC.NET 3.0, сборка 1076
var
  s:string;
  i,n:integer;
begin
  Write(Введите строку: ); ReadLn(s);
  for i:=Length(s) downto 1 do
    if s[i]=а then Insert( ,s,i+1);
  Writeln(Результат: ,s)
end.

Тестовое решение:
Введите строку: Это тестовая строка. Маша ела кашу.
Результат: Это тестова я строка . Ма ша  ела  ка шу.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку