Помогите пожалуйста Решить 2 задачи на языке Паскаль!

1)

По данному числу N распечатайте все целые степени двойки, не превосходящие N, в порядке возрастания.

Операцией возведения в степень пользоваться нельзя!

2)

В первый день спортсмен пробежал x километров, а затем он каждый день увеличивал пробег на 10% от предыдущего значения. По данному числу y определите номер дня, на который пробег спортсмена составит не менее y километров.

Программа получает на вход действительные числа x и y и должна вывести одно натуральное число.

1)

Program Pr1;
uses crt;
var n,i:integer;
x:real;
Begin
clrscr;
readln(n);
for i:=1 to n do if exp(i*ln(2))end.

 2)

Program Pr1;
uses crt;
var i,r,y:integer;
a,x:real;
begin
clrscr;
readln(x,y);
i:=1;
while x<=y do begin
x:=x+0.1*x;
i:=i+1;
end;
writeln(i);
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку