Пусть задана квадратная матрица А размера N × N (где N=7). В программе, написанной на языке Pascal, производится обработка в соответствии с программой:
const N=7;
VAR I, K:integer;
R,P:real;
A:array[1..N,1..N] of real;
begin
K:=0;
R:=0;
while K begin
for I:=1 to N-K do
begin
R:=R+1;
A[I,I+K]:= R;
end;
K:= K+1;
end;
P:= A[3,7];
writeln(P);
end.
Чему будет равно значение переменной Р по окончании выполнения программы?
В ответе запишите только полученное число без пробелов и каких-либо знаков препинания.

Ничему не будет равно значение переменной, так как программа не запустится. "while K begin" это вообще что значит? К не boolean, такая запись недопустима. 

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку