Для решения задачи задать случайным образом одномерный массив размерности N (вводится с клавиатуры) из целочисленных элементов, принадлежащих отрезку [-20;20]. Вывести на экран промежуточные результаты, полученные при вычислении значения заданного выражения.
Составить программу для вычисления
T=(R/(Q+1))+S
R - наименьший элемент массива;
Q - произведение элементов массива с нечетными номерами;
S - количество элементов, лежащих в интервале (A,B) (ввести с клавиатуры).
Var C:array[1..100] of Integer;
i,N,Q,R,A,B:integer;
T:real;
begin
Readln(N,A,B);
For i:=1 to N do
C[i]:=Random(-20,20);
R:=C[1];
Q:=1;
For i:=1 to N do
begin
If C[i]
If C[i] mod 2=1 then
Q:=Q*C[i];
If (C[i]>A) and (C[i]S:=S+1;
end;
T:=(R/(Q+1))+S;
Writeln(R, ,Q, ,S, ,T);
end.
Оцени ответ
