Даны два числа n и m. Создайте двумерный массив [n][m] и заполните его по следующим правилам: Числа, стоящие в строке 0 или в столбце 0 равны 1 (A[0][j]=1, A[i][0]=1). Для всех остальных элементов массива A[i][j]=A[i-1][j] A[i][j-1], то есть каждый элемент равен сумме двух элементов, стоящих слева и сверху от него.
Входные данные
Программа получает на вход два числа n и m.
Выходные данные
Выведите данный массив.
Примеры
входные данные
3 3
выходные данные
1 1 1
1 2 3
1 3 6
Program z1;
Var i,j,n,m:integer;
a: array [1..100, 1..100] of integer;
Begin
Write(Введите кол-во столбцов - ); Readln(n);
Write(Введите кол-во строк - ); Readln(m);
for i:=1 to n do
a[i][1]:=1;
for j:=1 to m do
a[1][j]:=1;
for i:=2 to n do
for j:=2 to m do
a[i][j]:=a[i-1][j]+a[i][j-1];
for i:=1 to n do begin
for j:=1 to m do
write(a[i][j], );
writeln;
end;
End.
Оцени ответ
