Составьте программу, которая заполняет массив a[1..10] случайными целыми числами в диапазоне от 1 до 10, затем преобразовывает его, увеличивая все элементы с четными значениями на 1. Если элементы с четными значениями отсуствуют, оставить массив без изменений.

Var ar:array[1..10] of integer;
i,k:integer;
begin;
randomize;
writeln(Array:);
for i:=1 to 10 do
 begin;
  ar[i]:=random(1,10);
  write(ar[i]:4);
  if ar[i] mod 2=0 then ar[i]:=ar[i]+1;
 end;
writeln;
writeln(Final array:);
for i:=1 to 10 do
write(ar[i]:4);
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку