1) Составьте программу, которая заполняет массив а[1..20] случайными целыми числами в диапазоне от 1 до 10 и находит среднее арефметическое элементов с четными значениями и нечетными индексами.

Если надо найти ср. арифметическое одновременно и четных чисел и нечетных индексов:

var
a:array[1..20] of integer;
i, k, s: integer;
begin
for i:=1 to 20 do begin
a[i]:=random(1,10);
if (a[i] mod 2=0)or(i mod 2<>0) then begin
k:=k+1; s:=s+a[i]; end; end
writeln((s/k):17:2);
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку