Напишите программу, запрашивающую у пользователя N целых чисел и выводящую на экран: а) количество нулей в последовательности; б) количество положительных чисел; в) количество отрицательных чисел.

Var n,k1,k2,k3,p,i:integer;
begin;
writeln(Type N:);
readln(n);
for i:=1 to n do
 begin;
  readln(p);
   if p=0 then inc(k1);
   if p>0 then inc(k2);
   if p<0 then inc(k3);
 end;
writeln(0:,k1);
writeln(+:,k2);
writeln(-:,k3);
end. 

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку