Напишите программу, запрашивающую у пользователя N целых чисел и выводящую на экран: а) количество нулей в последовательности; б) количество положительных
чисел; в) количество отрицательных. чисел на языке паскаль с++
Program z1;
Var i,n,a,b,c:integer;
m: array [1..1000] of integer;
Begin
write(Введите кол-во чисел - );
readln(n);
randomize;
a:=0; b:=0; c:=0;
for i:=1 to n do
begin
m[i]:=random(100)-50;
write (m[i], ); end; for i:=1 to n do if (m[i]=0) then a:=a+1; for i:=1 to n do if (m[i]>0) then b:=b+1; for i:=1 to n do if (m[i]<0) then c:=c+1; writeln; writeln (Кол-во нулей - ,a); writeln (Кол-во положительных чисел - ,b); writeln (Кол-во отрицательных чисел - ,c);End.
Оцени ответ
