Выведите все натуральные делители числа x в порядке возрастания (включая 1 и само число).
Входные данные
Вводится натуральное число x
Выходные данные
Выведите все делители числа x
Примеры
входные данные
7
выходные данные
1 7
входные данные
21
выходные данные
1 3 7 21

Var x,i:integer;
begin;
readln(x);
for i:=1 to x do
if x mod i=0 then writeln(i);
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку