Составить программу для ввода в ЭВМ произвольной вещественной матрицы размером M*N и вывода первого не равного заданному S элемента каждой строки.
Написать программу в PascalABC.NET
var
m, n, i, j: integer;
s: real;
a: array[,] of real;
begin
write(Введите S: );
read(s);
write(Введите M, N: );
read(m, n);
setlength(a, m + 1, n + 1);
writeln(Введите элементы матрицы: );
for i := 1 to m do
for j := 1 to n do
read(a[i, j]);
for i := 1 to m do
begin
for j := 1 to n do
if a[i, j] <> s then
begin
writeln(a[i, j]);
break;
end;
if a[i, j] = s then
writeln(-);
end;
end.
Пример:
Введите S: 7
Введите M, N: 3 4
Введите элементы матрицы:
7 4 3 7
3 5 1 4
7 7 7 7
4
3
-
Оцени ответ
