Составьте программу вычисления суммы элементов массива от второго положительного и до конца
Я составил такой код, но вот только сумму он определяет не так. Есть какие-то идеи?
program qq;
const N=10;
var a:array[1..N] of integer;
i,p,j,sum:integer;
begin
for i:=1 to N do
begin
a[i]:=random(20)-10;
write(a[i], );
end;
j:=0;
for i:=1 to N do
begin
if a[i]>0 then j:=j+1;
if j = 2 then p:=i;
end;
for i:=p+1 to N do
sum:=sum+a[i];
writeln();
writeln(Сумма элементов от второго положительного: ,sum);
end.
У вас что-то слишком сложная структура для такой задачи.
Предлагаю вариант покороче, скрин и исходник в приложении.
Складывает все числа (положительные и отрицательные) начиная со второго положительного включительно, то есть второй элемент так же будет задействован.
Оцени ответ
