Вести n чисел и найти среднее арифметическое. Написать программу и нарисовать блок схему.
#include
using namespace std;
int main(){
setlocale(LC_ALL,"Rus");
int N,dp,S,F,d;
S=0;F=0;d=0;
while(S<1){
cout<<"Выберите действие"<
cout<<"1.Ввод чисел"<
cout<<"Выполнить действие-";
cin>>dp;
switch(dp){
case 1:
cout<<"Введите число ";
cin>>N;
F=F+N;
d++;
break;
case 2:
S=(float)F/d;
break;
}
}
cout<<"Среднее арифметическое="< system("pause");
return 0;
}
Оцени ответ
