Ряд чисел Фибоначчи задается следующим образом: первые два числа равны 1 ( F 1 = F 2 = 1 ), а каждое следующее равно сумму двух предыдущих: F i = F i - 1 F i - 2 .
Напишите программу, которая вводит натуральное число N и заполняет массив из N элементов первыми N числами Фибоначчи. Входные данные Входная строка содержит размер массива N . Гарантируется, что 0 < N ≤ 40 . Выходные данные Программа должна вывести содержимое массива: первые N чисел Фибоначчи.
Примеры
входные данные 5
выходные данные 1 1 2 3 5
Program fib;
var i,ch,ch1,ch2,n:integer;
begin
write(n=);
readln(n);
ch:=0; ch1:=1;
for i:=1 to n do begin
ch2:=ch1;
ch1:=ch;
ch:=ch1+ch2;
write(ch:4);
end;
end.
ну если тебе надо с 1 то на
Оцени ответ
